Warning: Declaration of action_plugin_changes::register($controller) should be compatible with DokuWiki_Action_Plugin::register(Doku_Event_Handler $controller) in /volume1/web/dokuwiki/lib/plugins/changes/action.php on line 0 Warning: Declaration of syntax_plugin_code::handle($aMatch, $aState, $aPos, &$aHandler) should be compatible with DokuWiki_Syntax_Plugin::handle($match, $state, $pos, Doku_Handler $handler) in /volume1/web/dokuwiki/lib/plugins/code/syntax.php on line 42 Warning: Declaration of syntax_plugin_code::render($aFormat, &$aRenderer, &$aData) should be compatible with DokuWiki_Syntax_Plugin::render($format, Doku_Renderer $renderer, $data) in /volume1/web/dokuwiki/lib/plugins/code/syntax.php on line 42 mac_qemu [Protocol Engineering Lab.]

User Tools

Site Tools


mac_qemu

1. 맥 패키지 관리 시스템인 Homebrew 설치

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

2. qemu 2.2.0을 받기 위해 Homebrew의 qemu 패키지 설정을 다운 받음

cd /usr/local/
git checkout fce79940eb Library/Formula/qemu.rb

3. qemu 을 위해 gcc 4.2를 설치

brew install https://raw.github.com/Homebrew/homebrew-dupes/master/apple-gcc42.rb

4. qemu 가 필요로 하는 pkg-config 를 설치

brew install pkg-config

5. qemu 를 설치 (옵션으로 gcc 4.2 사용을 지정)

brew install qemu --env=std --cc=gcc-4.2

6. 설치 된 qemu 의 버전 정보를 확인

qemu-system-arm --version
mac_qemu.txt · Last modified: 2015/04/04 01:25 by jonghyouk